Ffmpeg error on MacBook m1 and GoPro Hero 7 silver

Hi, I tried to stitch the test videos on my MacBook and in the end I get an error about ffmeg.exe??

how could I solve this issue?

another question.
i have only two GoPro 7 silver. would this also works?
in hot conditions 4k isn’t possible with the 7 silver and I can only record in 1440p.
is this also possible and do I need special settings for the 7silver?

even if I couldn’t test it until now: I store my videos in the GoPro cloud. is there an option to upload it directly with the software?

the whole project looks a bit similar to a project witch I have supported in the last two years. but actionstitch is a local solution and they worked on a cloud based solution. this project was canceled.

thank you in advance.


What is exactly the error message? You can find it in the log file ~/Library/Application\ Support/actionstitch.com/ActionStitch/actionstitch.log.

ActionStitch by default only uses ffmpeg to merge the audio into the stitched video so you can disable the audio option to avoid this issue (you may actually have the stitched video without the audio in the Output directory),

According to my experience with GoPro 10, connecting the camera to a USB power bank alleviates the overheating problem and noticeably increases the recording time. Also, disable image stabilization and undistortion. If all of these do not work, you’ll have to record in 1440p.

I don’t think the GoPro cloud is open to third-party applications.

the exact error message is

i have stitched including audio.
the stitched video isn’t in the output directory.

what could I do to avoid the ffmpeg error on my Mac and get a stitched video including audio?

what about the Gopro7 silver? you spoke about GoPro 10. good to know the the GoPro 10 with external battery doesn´t have the overheating problem anymore, but I will use my existing gp 7 silver a bit longer.

Which setting do I have to set, if I would like to use my gp7 silver and

  1. record with 4k?
  2. record in 1440p?

This is actually a bug in the audio merging code that only occurs on macOS. I’ll fix that in the next release.

For now you can set audio to none in the stitching dialog to work around this bug.

What I suggested is to record with an external battery to see if that helps. Otherwise you’ll have to record in 1440p.

Hi @gchen ,

im still struggling with my gp 7 silver.
I couldn’t get a good preview in the stitching screen and it looks a bit confusing.

do I have to use another setting? I tried several cameras settings but got no other result.
I need a solution for 4k and 1080p videos.
the plan was to test it tomorrow during a match, but until now it makes no sense. thank you in advance for a feedback.

by the way, the Mac version seems a bit buggy. beside the ffmpeg bug, even there is no chance to close the program or find it in running apps. the only way to close it is to restart the Mac.

The objects in the videos are too close to the cameras for the stitching algorithm to work. Try taking videos outdoor.

You also need to take a calibration video such as this one and send the video to me, as GoPro 7 isn’t official supported. For the checkerboard you can print this one.

You can take the calibration video after recording the match, and use the same settings for the calibration and the match (same resolution, HyperSmooth disabled, and Wide mode).

Ok, thank you for your support!
I have done two videos with 4K and 1440p
I’ll send you a pm with a link to the videos.

To close ActionStitch, click the ActionStich icon on the menu bar and select Quit from the menu.

Thank you. I already saw it yesterday.
I wasn’t aware that running apps will appear there also… sorry.

I uploaded two calibration files for GoPro 7 to actionstitch-player/calibration at main · gilbertchen/actionstitch-player · GitHub

So instead of selecting a camera from the list in camera selection dialog, you can click Load from file to select the calibration file.

If you still can’t get good stitching results please send me the raw videos.

Hi @gchen,

looks much more better, but still not 100% ok.

I could sent you the first left and right clips.
Also I had temperature issues during the match so that I had to switch the video quality, so I have to sent you both variants.
how could I sent you the first left and right video for testing?
I havn´t enough online storage anymore…

A free Mega account will get you 20GB: https://mega.io/. Would that be enough? If not, send me just the 1440p videos only.

I only tried the 1400p version and it worked fine:

You need to select a frame after the cameras become stable. I usually prefer a frame a few seconds before the kickoff.

even if im too detailed ;-), what about this failures ?

hi @gchen I tried the 4k clips again.
this is the result

there is still a pixel error on the right side.
what is the reason for this?

ahh, ok, the result in the stitching screen looks ok… so there is no problem and its my fault, because I didnt start the process and just looked at the “setting screen”…
:see_no_evil: sorry!

lets wait how the result will be.
it would be good, if the sound issue on the Mac could be solved soon, to have also audio.
i will give you a feedback, after the stitching process is done-

unfortunately I get an error with the 4k videos.

what could be the reason for it?

This is the same error as Failed to read frame . .

The fix is to use a different video reader by running this command in terminal:

defaults write  ~//Library/Preferences/com.actionstitch.ActionStitch.plist stitch_source pyav

You’ll need to restart ActionStitch after running this command.

Hi @gchen ,

I would like to let you know, that it works!
Thank you for your support.
Did you already know, when you will fix the audio issue on the Mac?

Hi @gchen ,

now that i have the first test video, ofcourse i would like test the player.
would you be so kind to give me a “how to play local videos with the local play.html for idiots”.
I’m not an expert and I’m already failing at downloading the play.html file… :see_no_evil: :rofl:
i have stored the play.html, but its only a link and even if i read the instruction on github, i do not know how it should work…

and maybe you could be so kind to exlpain it for Windows and MAC?

Thank you very much for your support!!