Html Video Player problem with a generated .mp4

I did the stitching and it produced the .mp4 file.

If I try to play my video I got this message :

“The media could not be loaded, either because the server or network failed or because the format is not supported.”

If I enter the url to the .mp4 in my browser I can play the video. But if I append it to the player I got the previous message.

Here is the link to the video :

ActionStitch Player

This is the error message reported by Chrome:

Access to video at '' from origin '' has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource.

If that is your own web server, you can add Access-Control-Allow-Origin: * to your http server settings. Another way to avoid this issue is to host the file play.html on your server, which is available from GitHub - gilbertchen/actionstitch-player: 180 degree cylindrical video player

So the link will become:

Thanks it worked fine.

I needed to realign the audio in premiere pro as it was not in sync after the stitching export but’s it’s no big deal.

Do you know if we can adjust the .mp4 quality for the export ?

How much is the audio off by?

The bitrate is hardcoded at 8000kbps. Do you want it to be higher?

I’m processing the second half at the moment and I will see if the audio is in sync or not.

For the bitrate it’s ok for the moment, as I know that for the size of the video ant the time we need to figure the compromise quality/size :slight_smile:

I did modify the play.html for it to be in the perspective correction at startup. But I still need to move a little bit the “screen tilt” slider for the geometry to be applied correctly. I can do a screen recording of it to show you if you want.

Here is the video of what I talked previously :

Did you mean that the scene still looks curved after you adjust the screen tilt parameter? You’ll need to adjust the other 2 parameters as well. In particular, if you’re shooting the video with GAMSOD, the focal length should be around 2000.

I did modified the parameters in the play.html file for them to applied as soon I clic one of the link. But it seems that the “screen tilt” parameter is not applied at the load of the play.html as I need to move the slider back and forth for the value to be applied.

This is what I modified in the play.html file :

var perspectiveMode = false;


var controls = {
screenRotation: 30,
cameraY: -500,
focalLength: 2400

My setup is 2 GoPro Hero 8 Black

You need to set screen.rotation.z after creating the screen. Basically copy this line to line 726:

Thanks again, that did the trick :+1:

Here are the results stitched videos that have a little bit of audio/video offset.

Audio lag the video by a little bit than less a second :

1st half - YouTube

2nd half - YouTube

Can you check the original video to see if the audio is in sync? GoPro 8 is known to have an audio out-of-sync issue: GoPro Support

The original GoPro videos are all in sync.

Here I put the first clips of the 1st half (left and right) plus the result stitch for juste those 2 smaller clips if you want to do test with it but as I said previously, it’s no big deal for me to correct it in post after the stitching.

It could be cool in the future to be able to control the parameters for the mp4 export settings.

The audio offset in the resulting stitch seems to be around half a second. Here are the files :