Issue with stitching window

I just used my new rig for the first time which consists of GoPro Hero 11’s instead of the Gamsod’s I had been using. When I go through the process and aligning that all works fine, for the most part, but I am having 2 issues.

#1 is it seems to not be properly aligning the center lines correctly every time and

#2, the bigger issue is it is for some reason opening the stitch window in such a large screen that I cannot access the controls at the bottom of the window. When I try and click and drag to resize, the window is simply disappearing from my screen and I can’t do anything to bring it back. Any ideas? Should I try and take a video of it or something or do you already have an idea of what may be happening? I went ahead and updated to 1.0.4 thinking that may solve it, but no dice.

PS, I am using the GoPro’s in the full frame 5.7k mode. If that matters.

#1 did you choose ‘GoPro Hero 11 Black 5.7k full (8:7)’ from the list? Also make sure HyperSmooth is off and the FOV is wide.

#2 The stitch dialog isn’t resizable unfortunately. But can you move the dialog around by holding the window title? Which OS are you running?

#1- Yes I did choose the proper setting and yes, Hypersmooth is off on both cams and wide is the selection. I ended up having to manually stitch, which in general isn’t a pain, but with the screen issue it is.

#2- Darn. I can move it around but I cannot move the top passed the top of the screen. If I right click and select “Move” I CAN shift it up higher, but the second I left click or hit enter to drop the app, it snaps back down so the top of the window is even with the top of the screen.

Is there any way to make the stitch dialog re-sizable?

I am running Windows 10

The only work around I was able to use is that, luckily, I have dual monitors so I was able to tell the computer that they were at different heights (even though they are not), putting the top of one monitor at the height of the middle of the other monitor. If I open the program on the “Higher” monitor I can partially drag it over to the “Lower” monitor and be able to see the controls at the bottom (since the top is “Off screen” due to the height difference). This is a pretty big hassle, but it did work.

If manual stitch works then you’re using the correct camera mode. I believe this is an issue in the automatic stitching algorithm that only occurs in the full mode – the height is much larger so the algorithm may choose the sky or trees in the distance to find feature points.

I’ll make the stitch dialog resizable in the next update.

Sounds about right. The height of the stitch window was massive for sure. I will keep my eyes peeled for an update and in the meantime I do have a workaround that works in a pinch. Thanks for looking into it!

So I’ve used these cameras for the second time today and when I went to stitch the auto stitch didn’t work at all. But this time when I went to manual stitch I’m getting terrible results. I’ve tried multiple times and it keeps failing.

I’m using GoPro 11’s
5.3k 8x7 wide
HyperSmooth is off on both

I’ll try again a few more times. Last time I was able to manually stitch but it completely failing this time.

Any ideas?

Can you share the raw videos for me to take a look? I just need one left segment and one right segment.

The videos are like 10.7gb per part. I could upload 20gb worth to a Dropbox folder if you want. I wouldn’t want to simply chop a piece off from each just in case it changes something. Is that what you are looking for?

That should be fine if you have enough Dropbox space.

I do. Do you just want the link here or in some sort of a private message?

You can send the link in a private message.

Link to videos sent. It was a very windy day and maybe that is affecting the stitch? No matter what part of the full video I attempted to manually stitch or how many points I was able to give it, it would fail horribly. I tried anywhere from 4-8 points. Most times looking like the video was going into Hyper Drive!

Good morning. Just checking to see if you were able to resolve this? I have another game from yesterday I’m trying to stitch and I’m having the same issue as the last two. Please let me know. Thanks!

It turned out that the calibration for the GoPro 11 full 8:7 mode wasn’t done correctly – I may have recorded the calibration video with HyperSmooth on without realizing it. Here is the calibration data with HyperSmooth off:

  "distortion_coefficients": [0.955511037479108,-0.06948049061703017,-0.00015965343831754754,-3.503190929822295e-05,-0.008655522141077199,1.2525766581502606,0.09247804849002858,-0.03384576767177371,0.0,0.0,0.0,0.0,0.0,0.0
  "intrinsic_matrix": [2335.9913060867166,0.0,2662.3707651563573,0.0,2336.100809649267,2323.4279513491088,0.0,0.0,1.0

Save the above to a json file and use the ‘Load from file’ button in the camera selection dialog to use it. The stitching should be perfect!

Nailed it! Thank you so much, stitched perfectly on my first try! Now if we can just get that stitching window re-sizeable I will be golden.

Thanks again!

I’ve corrected the calibration data in the web API used by ActionStitch . After you restart ActionStitch the camera list will update automatically and you can just select ‘GoPro Hero 11 Black 5.3k full (8:7)’. Note that it said 5.7k before which was incorrect.

Excellent. Thank you!