Gopro Hero 10 Settings

Very excited to try out your software (just completed a stitch with your sample videos and it turned out great)

Do you have spcific recommendations for the best settings to record a soccer game using the Gopro Hero 10? For example, would you recommend wide angle vs medium, etc? Would you recommend 4k30fps or 108060fps, etc.?

In some ways, I’m asking what setting you used in the sample videos for the type of angle used and then whether or not is ok to adjust video quality (i.e., 4k/1080 and fps) for your software. I noticed when selecting the camera in and the video that in the ‘select camera’ options Gopro Hero 10 5.3K was the only thing listed. Should we not se 4k.

Only 5.3k is supported because the calibration was done for 5.3k.

You should enable the Tripod/Stationary mode (swipe down to show the dashboard and the bottom-left icon shows the current video performance mode). In this mode HyperSmooth is disabled and the angle is wide, both of which is required by ActionStitch.

60fps should work too, however I always shoot in 30fps.

Thanks for providing those settings. I have now filmed my first soccer game using my own cameras to test it out. It seemed like everything came out, but when I went to stitch it together using your ActionStitch software I received the message ‘License Issued to Different Host User.’ I have only tried stitching the sample videos you provided and that had turned out great. I’m happy to buy a license (though I can’t figure out how to actually purchase the license and was hoping to try one sample using my own video from my owner cameras). Can you let me either how to purchase a license or how to allow me to test on my own video. I saw a forum entry on changing the registry, though I’m bit unfamiliar with registry and if that is required I would probalby need pretty detailed instrucitons. Thanks for your help, Looking forward to testing it out/buying it.

First you need to open Registry Editor. This is how you do it: How to open Registry Editor in Windows 10

Once Registry Editor is running, in the left, find the key HKEY_CURRENT_USER → Software → → ActionStitch. Now if you click this registry key, the right panel will show all values under this key. Click the one that says ‘license’. This is the value that you want to delete (right click to bring up the pop-up menu).

After that, you’ll need to restart ActionStitch. Not just close the window. You’ll need to right click the system tray icon and then select Quit. Otherwise it will remain running in the background.

Great, that worked and the stitched video turned out nice (I need to do better at getting the exposures right between the two camers, but the video turned out really nice). One question on the playback using the browser based player you developed. I was not able to get a video to playback back in your browser based player. These were the steps followed:

  1. Uploade the video to Google Drive and made available to anyone with the link (viewer access to anyone with the link was granted, effectively public to anyone with the link)
  2. Appended the link to the provided in the software guide: ActionStitch Player
  3. The link was then the following: ActionStitch Player
  4. That resulted in the message ’ no compatible source was found for this media.’
  5. I performed some further research and learned that a traditional Google Drive link is not necessarily a direct link to the file and found that the following would provide a direct link to the file. So after appending to what should be a direct link to the file I tried the following:
    ActionStitch Player &export=download
  6. That resulted in the same message ‘no compatible source was found for this media.’

Is there a way to make a file hosted ono google drive work with the built in browser you developed. Your browser player really is quite nice with the pan and zoom features.

Thanks for your help.

Try this link:

The perspective mode doesn’t work though, because of a cross-origin issue.

For both cameras to get the same exposure, turn on the spot meter mode and then select one point on each camera such that they roughly point to the same place on the field. Don’t lock the exposure (when the lock icon appears) because this will make the exposure even worse.

That’s great. Thank you for your help to get that to play in your the browser video player you developed. Is there a better site to store it on to allow the perspective mode (i.e., dropbox, box, etc.)?

Also, thanks for the help with the exposure.

You can disable the CORS policy in Chrome: Run Chrome browser without CORS and everything should work fine.

I’ve also tested Dropbox, which doesn’t need the CORS policy to be disabled. However, the url should be changed according to How to generate a Dropox direct download link | Zapier

I first want to say tahnk you for all of your help–what you have created here is very neat! I hope my questions are not bothersome. Yesterday, after you sent that modified link for the google drive file location I was able to view in your browser-based video player and it worked great. Later in the evening I went to view it again and I reciged the following error message: “The media could not be loaded, either because the server or network failed or because the format is not supported.”

I waited until today just in case there was some form of a server issue, but received the message again when trying today. I have confirmed that the file ID on google drive has not changed and that the permissions for the file are still the same (i.e., any one with the link can view). Do you know what I might be having this issue?

In case it is helpful to know in answering my question above, I did not do anything related to the cross-origin issue in Chrome (meaning I did not adjust anything in the Chrome browser to run it without CORS).

Sorry this is my fault. I made a change to play.html to remove the cross-origin settings (Remove crossorigin · gilbertchen/actionstitch-player@735edda · GitHub) but later realized that this broke the perspective view for every website, so I reverted it back.

Right now the only way to watch a Google Drive video is to disable the CORS policy in Chrome.

I see, thanks for trying to get the cross origin piece to work. Have you already reverted it back? If I take the link that you had provided earlier (pasted below), it is still not working properly and I receive the message ‘The media could not be loaded, either because the server or network failed or because the format is not supported.’ It worked yesterday when you first provided it, but it doesn’t seem to be working now.

This is the link you had provided:


If I paste in just the google drive direct link, it seems to be working, so I think the google drive link is still functioning. However, the browser player does not seem to be playing it. Direct google drive link pasted below:


I’m perfectly fine i fthe google drive file isn’t able to play using the perspective view. Please let me know if there is something I need to change on my end for it work properly. Thanks again for all of your help.

Sorry, I think I may have misread your last post before I wrote my last post. Is it possible to get the Google Drive file to player again in the regular view of your browser-based video player. I know it was working yeterday when you first provided the recommended link with my own video. I’m perfectly fine if the perspective view does not work, I would just love for it to work with the regular view in your brower player again. I’m trying to allow grandparents to watch it and I don’t think they are going to be able to disable able the CORS policy.

Again, if it is possible to get the google drive video working in the regular view of your browser player that would be fantastic. Thanks again for your help!

You can use this link:

That is, replace play.html with play2.html, which has crossorigin="anonymous" removed so that it can work with Google Drive links.

That’s great, thank you so much!

Thanks again for our help. I could view the videos great in browsers on several different computer. When trying view from an android phone and a an iPad pro, the video would not load. On both of those devices I tried to view the video in a Chrome browser. Is there anything I need to do on a phone or ipad to watch the videos using your browser video player? The message I received when trying to watch was the one you listed in your last post.

That is because the resolution is too high for mobile devices. For example, the demo video ( on doesn’t play on iphone/ipad, and I had to resize to half size for it to play:

Is it possible to use the player with videos uploaded to YouTube?


I don’t think there is a way to access a YouTube video directly from another site (like, where the play.html file is hosted). Even if there is, YouTube won’t give the video in the original resolution. I tried to update 8k videos to YouTube but could only play them at 4k.